Il y a quelques jours, j'ai été contacté via twitter par @jigsaw956 pour l'aider à se connecter à tax-on-web bon, j'ai éprouvé, comme d'autres[1], quelques difficultés à utiliser ma carte d'identité Belge sur les sites de tax-on-web et de l'O.N.V.A en étant avec un ordinateur utilisant Ubuntu.
Perso, voici ma config du moment : Ubuntu 10.10, Firefox 3.6.16

Et là, sur twitter, @JHERREMAN a trouvé la solution qui a fonctionné chez moi.
Bien que j'ai dû aussi installer un plug-in que j'oubliai ( Merci à @webatou )
Bon, je vais vous expliquer ce que j'ai fait :

  1. Installer le plug-in firefox : https://addons.mozilla.org/fr/firefox/addon/belgium-eid/
  2. Installer en tapant dans votre "Gestion des logiciels" la marque de votre lecteur (Perso -> ACR38U) ( Lien de @JHERREMAN)
  3. Redemarrer Firefox et aller dans certificats pour accepter le certificat belge : Edition->Préférence->Avancé->chiffrement->Afficher les certificats->Autorités->Belgium Root CA (cocher les cases dans modifier (toutes les cases ). Perso, j'ai fais la même procédure (cocher les cases dans modifier la confiance) pour Belgium root CA2/Citizen CA et Governement CA) et ça fonctionne! ( Lien de @JHERREMAN)

Depuis, j'ai réussi à me connecter aux différents service. :)
Je signal toujours que ces modifications sont à reproduire pour tout les utilisateurs d'un même ordi.

Édit du 17 mai 2012 : J'ai juste mis à jour le plug-in pour firefox https://addons.mozilla.org/fr/firefox/addon/belgium-eid/, puis j'ai relancer firefox et tout à fonctionner comme il faut ! :)

Note

[1] Dans le désordre, il y a @jigsaw956, @webatou, @JHERREMAN, et surement pleins d'autres.